re = /https?:\/\/(?|media\.giphy\.com\/media\/([^ \/\n]+)\/giphy\.gif|i\.giphy\.com\/([^ \/\n]+)\.gif|giphy\.com\/gifs\/(?:.*-)?([^ \/\n]+))/i
str = 'http://i.giphy.com/VmzI60RQG0fuw.gif
https://media.giphy.com/media/VmzI60RQG0fuw/giphy.gif
http://giphy.com/gifs/music-videos-mariah-carey-dreamlover-VmzI60RQG0fuw
http://giphy.com/gifs/VmzI60RQG0fuw'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end