import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bEtc/\\S*|((?:GMT|UTC)?\\+\\d{2}(?:[:.]\\d{2})?)";
final String string = "GMT+01:00\n"
+ "UTC+01:00\n"
+ "UTC+01\n"
+ "+01:00\n\n"
+ "Etc/GMT+01:00\n"
+ "Etc/UTC+01:00\n"
+ "Etc/UTC+01";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}