// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bEtc/\S*|((?:GMT|UTC)?\+\d{2}(?:[:.]\d{2})?)").unwrap();
let string = "GMT+01:00
UTC+01:00
UTC+01
+01:00
Etc/GMT+01:00
Etc/UTC+01:00
Etc/UTC+01";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}