const regex = /<AUDT:INFO>.* Passwordstate:/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<AUDT:INFO>.* Passwordstate:', 'gm')
const str = `08 21 2020 08:15:25 10.72.1.17 <AUDT:INFO> 2020-08-21 08:14:25 10.72.1.17 Passwordstate: Fake User (fakedoamin\\FakeUser) initiated a Remote Session connection to Host 'fakeserver.fakedomain.tld' using the manual credentials of 'FakeUser'.Fake User (fakedoamin\\FakeUser) initiated a Remote Session connection to Host 'fakeserver.fakedomain.tld' using the manual credentials of 'FakeUser'. Reason = Task 31117 Checking GPT files Client IP Address = 10.14.72.232`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}