re = /([-0-9]+ to [-0-9]+)/
str = 'user levels 2-20 to 2-25 not ready. dont capture 1-10. capture 3-99 to 3-100.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end