// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([-0-9]+ to [-0-9]+)").unwrap();
let string = "user levels 2-20 to 2-25 not ready. dont capture 1-10. capture 3-99 to 3-100.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}