package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^\w+[.]\w+$|^\w+@\w+[.]com$`)
var str = `string.string
string@string.com
some.incorrect@format.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}