$re = '/^\w+[.]\w+$|^\w+@\w+[.]com$/im';
$str = 'string.string
string@string.com
some.incorrect@format.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);