const regex = /^New:\s(.*)\s\[?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^New:\\s(.*)\\s\\[?', '')
const str = `New: I Knew It Was You: Rediscovering John Cazale [2009] || Me and What's left [2000]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}