$re = '/^New:\s(.*)\s\[?/';
$str = 'New: I Knew It Was You: Rediscovering John Cazale [2009] || Me and What\'s left [2000]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);