#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[\s\S]*^——$|\G(?!^))\R\K(?!^——$).+"
Local $sString = "TITLE" & @CRLF & _
"——" & @CRLF & _
"1 nuit " & @CRLF & _
"1 nuit " & @CRLF & _
"1 nuit " & @CRLF & _
"1 nuit " & @CRLF & _
"1 nuit " & @CRLF & _
"total : 5 nuits " & @CRLF & _
"——" & @CRLF & _
"1 nuit " & @CRLF & _
"1 nuit" & @CRLF & _
"1 nuit" & @CRLF & _
"total : 3 nuits " & @CRLF & _
"——" & @CRLF & _
"1 nuit " & @CRLF & _
"1 nuit" & @CRLF & _
"1 nuit" & @CRLF & _
"1 nuit" & @CRLF & _
"1 nuit" & @CRLF & _
"1 nuit" & @CRLF & _
"——"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")