import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\s\\S]*^——$|\\G(?!^))\\R\\K(?!^——$).+";
final String string = "TITLE\n"
+ "——\n"
+ "1 nuit \n"
+ "1 nuit \n"
+ "1 nuit \n"
+ "1 nuit \n"
+ "1 nuit \n"
+ "total : 5 nuits \n"
+ "——\n"
+ "1 nuit \n"
+ "1 nuit\n"
+ "1 nuit\n"
+ "total : 3 nuits \n"
+ "——\n"
+ "1 nuit \n"
+ "1 nuit\n"
+ "1 nuit\n"
+ "1 nuit\n"
+ "1 nuit\n"
+ "1 nuit\n"
+ "——";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}