package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+38\(0\d{2}\)\s\d{3}\s\d{2}\s\d{2}$`)
var str = `+38(098) 578 27 85`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}