$re = '/^\+38\(0\d{2}\)\s\d{3}\s\d{2}\s\d{2}$/m';
$str = '+38(098) 578 27 85';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);