package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(\.\d+).*$`)
var str = `asdf .23 asdf
asdf aasdf .4455 asdfw`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}