$re = '/^.*(\.\d+).*$/m';
$str = 'asdf .23 asdf
asdf aasdf .4455 asdfw';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);