package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\p{L}{2}\p{N}{3,5}\b`)
var str = `foo-foo-AB1234-foo-AB12345678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}