$re = '/\b\p{L}{2}\p{N}{3,5}\b/';
$str = 'foo-foo-AB1234-foo-AB12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);