using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"xxx ([a-z]+)(?:, ([a-z]+)){3} xxx";
string input = @"xxx one, two, three, four xxx";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}