$re = '/xxx ([a-z]+)(?:, ([a-z]+)){3} xxx/';
$str = 'xxx one, two, three, four xxx';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);