const regex = /(\b.+?\b)\1\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b.+?\\b)\\1\\b', 'g')
const str = `are blue and then and then more and then and then more very bright`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);