import re
regex = re.compile(r"(\b.+?\b)\1\b")
test_str = "are blue and then and then more and then and then more very bright"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)