re = /^([\s*\w]+[\.\\\/\-\@\s]*)+[\s\w]$/
str = '\\";alert(\'XSS\');//
</script><script>alert("XSS");</script>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end