#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<.*?>(\d{1,2})<.*?>\s*<.*?>(.*?)<.*?>\s*<.*?>(.*?)<.*?>"
Local $sString = "<head><title>Popular Baby Names</title>" & @CRLF & _
"<meta name="dc.language" scheme="ISO639-2" content="eng">" & @CRLF & _
"<meta name="dc.creator" content="OACT">" & @CRLF & _
"<meta name="lead_content_manager" content="JeffK">" & @CRLF & _
"<meta name="coder" content="JeffK">" & @CRLF & _
"<meta name="dc.date.reviewed" scheme="ISO8601" content="2006-03-10">" & @CRLF & _
"<link rel="stylesheet" href="../OACT/templatefiles/master.css" type="text/css" media="screen">" & @CRLF & _
"<link rel="stylesheet" href="../OACT/templatefiles/print.css" type="text/css" media="print">" & @CRLF & _
"</head>" & @CRLF & _
"<body bgcolor="#ffffff" text="#000000" topmargin="1" leftmargin="0">" & @CRLF & _
"<table width="100%" border="0" cellspacing="0" cellpadding="4">" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr> " & @CRLF & _
" <td class="sstop" valign="bottom" align="left" width="25%">" & @CRLF & _
" Social Security Online" & @CRLF & _
" </td>" & @CRLF & _
" <td valign="bottom" class="titletext">" & @CRLF & _
" <!-- sitetitle -->Popular Baby Names" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#333366"><td colspan="2" height="1"></td></tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="graystars" width="25%" valign="top">" & @CRLF & _
" <a href="../OACT/babynames/">Popular Baby Names</a></td>" & @CRLF & _
" <td valign="top"> " & @CRLF & _
" <a href="http://www.ssa.gov/"><img src="/templateimages/tinylogo.gif"" & @CRLF & _
" width="52" height="47" align="left"" & @CRLF & _
" alt="SSA logo: link to Social Security home page" border="0"></a>" & @CRLF & _
" <h1>Popular Names by Birth Year</h1>September 11, 2014</td>" & @CRLF & _
" </tr>" & @CRLF & _
"</tbody></table>" & @CRLF & _
"<script type="text/javascript" src="../OACT/babynames/chkinput.js"></script>" & @CRLF & _
"" & @CRLF & _
"<table width="100%" border="0" cellspacing="0" cellpadding="4" summary="formatting">" & @CRLF & _
" <tr valign="top">" & @CRLF & _
" <td width="25%" class="greycell">" & @CRLF & _
" <a href="../OACT/babynames/background.html">Background information</a>" & @CRLF & _
" <p><br />" & @CRLF & _
" Select another <label for="yob">year of birth</label>?<br />" & @CRLF & _
" <form name="popnames" method="post" action="/cgi-bin/popularnames.cgi"" & @CRLF & _
" onSubmit="return submitIt();">" & @CRLF & _
" <input type="text" name="year" id="yob" size="4" value="2012"><input type="hidden" name="top" value="25"><input type="hidden" name="number" value="">" & @CRLF & _
" <input type="submit" value=" Go "></form>" & @CRLF & _
" </td>" & @CRLF & _
" <td><p align="center"><table width="$tablewidth" border="1" bordercolor="#aaabbb" cellpadding="2" cellspacing="0" summary="Popularity for top 25">" & @CRLF & _
" <caption><h2>Popularity in 2012</h2></caption>" & @CRLF & _
" <tr align="center" valign="bottom">" & @CRLF & _
" <th scope="col" width="12%" bgcolor="#efefef">Rank</th>" & @CRLF & _
" <th scope="col" width="$colwidth" bgcolor="#99ccff">Male name</th>" & @CRLF & _
" <th scope="col" bgcolor="pink" width="41%">Female name</th></tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>1</td> <td>Jacob</td> <td>Sophia</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>2</td> <td>Mason</td> <td>Emma</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>3</td> <td>Ethan</td> <td>Isabella</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>4</td> <td>Noah</td> <td>Olivia</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>5</td> <td>William</td> <td>Ava</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>6</td> <td>Liam</td> <td>Emily</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>7</td> <td>Michael</td> <td>Abigail</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>8</td> <td>Jayden</td> <td>Mia</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>9</td> <td>Alexander</td> <td>Madison</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>10</td> <td>Aiden</td> <td>Elizabeth</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>11</td> <td>Daniel</td> <td>Chloe</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>12</td> <td>Matthew</td> <td>Ella</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>13</td> <td>Elijah</td> <td>Avery</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>14</td> <td>James</td> <td>Addison</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>15</td> <td>Anthony</td> <td>Aubrey</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>16</td> <td>Benjamin</td> <td>Lily</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>17</td> <td>Joshua</td> <td>Natalie</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>18</td> <td>Andrew</td> <td>Sofia</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>19</td> <td>Joseph</td> <td>Charlotte</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>20</td> <td>David</td> <td>Zoey</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>21</td> <td>Jackson</td> <td>Grace</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>22</td> <td>Logan</td> <td>Hannah</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>23</td> <td>Christopher</td> <td>Amelia</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>24</td> <td>Gabriel</td> <td>Harper</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr align="right">" & @CRLF & _
" <td>25</td> <td>Samuel</td> <td>Lillian</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr><td colspan="3"><small>Note: Rank 1 is the most popular," & @CRLF & _
"rank 2 is the next most popular, and so forth. " & @CRLF & _
"</table></p>" & @CRLF & _
"</td></tr></table>" & @CRLF & _
"<table class="printhide" width="100%" border="0" cellpadding="1" cellspacing="0">" & @CRLF & _
" <tr bgcolor="#333366"><td height="1" colspan="2"></td></tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td width="26%" valign="middle"> </td>" & @CRLF & _
" <td valign="top" class="seventypercent">" & @CRLF & _
" <a href="http://www.ssa.gov/privacy.html">Privacy Policy</a> " & @CRLF & _
" | <a href="http://www.ssa.gov/websitepolicies.htm">Website Policies" & @CRLF & _
" & Other Important Information</a> " & @CRLF & _
" | <a href="http://www.ssa.gov/sitemap.htm">Site Map</a></td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>" & @CRLF & _
"</body></html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")