# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<.*?>(\d{1,2})<.*?>\s*<.*?>(.*?)<.*?>\s*<.*?>(.*?)<.*?>"
test_str = ("<head><title>Popular Baby Names</title>\n"
"<meta name=\"dc.language\" scheme=\"ISO639-2\" content=\"eng\">\n"
"<meta name=\"dc.creator\" content=\"OACT\">\n"
"<meta name=\"lead_content_manager\" content=\"JeffK\">\n"
"<meta name=\"coder\" content=\"JeffK\">\n"
"<meta name=\"dc.date.reviewed\" scheme=\"ISO8601\" content=\"2006-03-10\">\n"
"<link rel=\"stylesheet\" href=\"../OACT/templatefiles/master.css\" type=\"text/css\" media=\"screen\">\n"
"<link rel=\"stylesheet\" href=\"../OACT/templatefiles/print.css\" type=\"text/css\" media=\"print\">\n"
"</head>\n"
"<body bgcolor=\"#ffffff\" text=\"#000000\" topmargin=\"1\" leftmargin=\"0\">\n"
"<table width=\"100%\" border=\"0\" cellspacing=\"0\" cellpadding=\"4\">\n"
" <tbody>\n"
" <tr> \n"
" <td class=\"sstop\" valign=\"bottom\" align=\"left\" width=\"25%\">\n"
" Social Security Online\n"
" </td>\n"
" <td valign=\"bottom\" class=\"titletext\">\n"
" <!-- sitetitle -->Popular Baby Names\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#333366\"><td colspan=\"2\" height=\"1\"></td></tr>\n"
" <tr>\n"
" <td class=\"graystars\" width=\"25%\" valign=\"top\">\n"
" <a href=\"../OACT/babynames/\">Popular Baby Names</a></td>\n"
" <td valign=\"top\"> \n"
" <a href=\"http://www.ssa.gov/\"><img src=\"/templateimages/tinylogo.gif\"\n"
" width=\"52\" height=\"47\" align=\"left\"\n"
" alt=\"SSA logo: link to Social Security home page\" border=\"0\"></a>\n"
" <h1>Popular Names by Birth Year</h1>September 11, 2014</td>\n"
" </tr>\n"
"</tbody></table>\n"
"<script type=\"text/javascript\" src=\"../OACT/babynames/chkinput.js\"></script>\n\n"
"<table width=\"100%\" border=\"0\" cellspacing=\"0\" cellpadding=\"4\" summary=\"formatting\">\n"
" <tr valign=\"top\">\n"
" <td width=\"25%\" class=\"greycell\">\n"
" <a href=\"../OACT/babynames/background.html\">Background information</a>\n"
" <p><br />\n"
" Select another <label for=\"yob\">year of birth</label>?<br />\n"
" <form name=\"popnames\" method=\"post\" action=\"/cgi-bin/popularnames.cgi\"\n"
" onSubmit=\"return submitIt();\">\n"
" <input type=\"text\" name=\"year\" id=\"yob\" size=\"4\" value=\"2012\"><input type=\"hidden\" name=\"top\" value=\"25\"><input type=\"hidden\" name=\"number\" value=\"\">\n"
" <input type=\"submit\" value=\" Go \"></form>\n"
" </td>\n"
" <td><p align=\"center\"><table width=\"$tablewidth\" border=\"1\" bordercolor=\"#aaabbb\" cellpadding=\"2\" cellspacing=\"0\" summary=\"Popularity for top 25\">\n"
" <caption><h2>Popularity in 2012</h2></caption>\n"
" <tr align=\"center\" valign=\"bottom\">\n"
" <th scope=\"col\" width=\"12%\" bgcolor=\"#efefef\">Rank</th>\n"
" <th scope=\"col\" width=\"$colwidth\" bgcolor=\"#99ccff\">Male name</th>\n"
" <th scope=\"col\" bgcolor=\"pink\" width=\"41%\">Female name</th></tr>\n"
"<tr align=\"right\">\n"
" <td>1</td> <td>Jacob</td> <td>Sophia</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>2</td> <td>Mason</td> <td>Emma</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>3</td> <td>Ethan</td> <td>Isabella</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>4</td> <td>Noah</td> <td>Olivia</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>5</td> <td>William</td> <td>Ava</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>6</td> <td>Liam</td> <td>Emily</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>7</td> <td>Michael</td> <td>Abigail</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>8</td> <td>Jayden</td> <td>Mia</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>9</td> <td>Alexander</td> <td>Madison</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>10</td> <td>Aiden</td> <td>Elizabeth</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>11</td> <td>Daniel</td> <td>Chloe</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>12</td> <td>Matthew</td> <td>Ella</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>13</td> <td>Elijah</td> <td>Avery</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>14</td> <td>James</td> <td>Addison</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>15</td> <td>Anthony</td> <td>Aubrey</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>16</td> <td>Benjamin</td> <td>Lily</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>17</td> <td>Joshua</td> <td>Natalie</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>18</td> <td>Andrew</td> <td>Sofia</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>19</td> <td>Joseph</td> <td>Charlotte</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>20</td> <td>David</td> <td>Zoey</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>21</td> <td>Jackson</td> <td>Grace</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>22</td> <td>Logan</td> <td>Hannah</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>23</td> <td>Christopher</td> <td>Amelia</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>24</td> <td>Gabriel</td> <td>Harper</td>\n"
"</tr>\n"
"<tr align=\"right\">\n"
" <td>25</td> <td>Samuel</td> <td>Lillian</td>\n"
"</tr>\n"
"<tr><td colspan=\"3\"><small>Note: Rank 1 is the most popular,\n"
"rank 2 is the next most popular, and so forth. \n"
"</table></p>\n"
"</td></tr></table>\n"
"<table class=\"printhide\" width=\"100%\" border=\"0\" cellpadding=\"1\" cellspacing=\"0\">\n"
" <tr bgcolor=\"#333366\"><td height=\"1\" colspan=\"2\"></td></tr>\n"
" <tr>\n"
" <td width=\"26%\" valign=\"middle\"> </td>\n"
" <td valign=\"top\" class=\"seventypercent\">\n"
" <a href=\"http://www.ssa.gov/privacy.html\">Privacy Policy</a> \n"
" | <a href=\"http://www.ssa.gov/websitepolicies.htm\">Website Policies\n"
" & Other Important Information</a> \n"
" | <a href=\"http://www.ssa.gov/sitemap.htm\">Site Map</a></td>\n"
" </tr>\n"
"</table>\n"
"</body></html>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.