#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*?(?=abc)|.*?(?=a.c)|.*?(?=def)|.*?(?=%#@)|.*?(?=1z;))(.{3})"
Local $sString = "1z;%#@defarcabcaqcdef%#@1z;" & @CRLF & _
"1z;%#@defarcabaqcdef%#@1z;" & @CRLF & _
"1z;%#@defacabacdef%#@1z;" & @CRLF & _
"1z;%#@deacabacdf%#@1z;" & @CRLF & _
"foo;%@deaabade#@1z;barbbbaarr3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")