import Foundation
let pattern = ##"(?m)^(?:.*?(?=abc)|.*?(?=a.c)|.*?(?=def)|.*?(?=%#@)|.*?(?=1z;))(.{3})"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
1z;%#@defarcabcaqcdef%#@1z;
1z;%#@defarcabaqcdef%#@1z;
1z;%#@defacabacdef%#@1z;
1z;%#@deacabacdf%#@1z;
foo;%@deaabade#@1z;barbbbaarr3
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)