package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bhttps?:\/\/([^\/.]+)`)
var str = `http://spappsdev.domain.com/sites/sitename/
http://spappsdev/sites/sitename/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}