$re = '/\bhttps?:\/\/([^\/.]+)/m';
$str = 'http://spappsdev.domain.com/sites/sitename/
http://spappsdev/sites/sitename/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);