$re = '/(?<=[b-df-hj-np-tv-z])[aeiou]{2,}(?=[b-df-hj-np-tv-z]|$)/m';
$str = '_abaab_aabaabaaeraaa_babaaa%abaa
^^ ^^ ^^^ ^^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);