re = /(?<=[b-df-hj-np-tv-z])[aeiou]{2,}(?=[b-df-hj-np-tv-z]|$)/m
str = '_abaab_aabaabaaeraaa_babaaa%abaa
^^ ^^ ^^^ ^^'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end