const regex = new RegExp('(?<!\\d)(?!2016(?!\\d))\\d{3,}', 'gm')
const str = `Employee ID DF856, Year 2016, Department Finance, Team 2, Location 112 20161 12016 120162`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}