re = /(?<!\d)(?!2016(?!\d))\d{3,}/m
str = 'Employee ID DF856, Year 2016, Department Finance, Team 2, Location 112 20161 12016 120162'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end