import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ # Assert begin of line\n"
+ " (?= # First zero-with lookahead\n"
+ " ( # Capturing group 1\n"
+ " a # Match a\n"
+ " (?1)? # Recurse group 1 optionally\n"
+ " b # Match b\n"
+ " ) # End of group 1\n"
+ " c+ # Match c one or more times\n"
+ " ) # End of the first lookahead\n\n"
+ " (?= # Second zero-with lookahead\n"
+ " a+ # Match a one or more times\n"
+ " ( # Capturing group 2\n"
+ " b # Match b\n"
+ " (?2)? # Recurse group 2 optionally\n"
+ " c # Match c\n"
+ " ) # End of group 2\n"
+ " ) # End of the second lookahead\n"
+ "a+b+c+ # Match each of a,b and c one or more times\n"
+ "$ # Assert end of line";
final String string = "abc\n"
+ "aabbcc\n"
+ "aaabbbccc\n\n"
+ "abbc\n"
+ "aabbc\n"
+ "aabbbccc\n\n"
+ "ab\n"
+ "aabb\n"
+ "aaabbb";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}