using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=[A-Z])([A-Za-z0-9""'. ]{50,}\.)";
string input = @"<>123Acdiiiiiiiiiiiiii iiiiiiiiiiiii iiii iiiiiii iiii iii iiiiiiiiiiiiiiiiiiiiiii iiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii iiiiiiiiii iiiiiiiiii iiiiiiiii iiiiii.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}