const regex = /(?=[A-Z])([A-Za-z0-9"'. ]{50,}\.)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=[A-Z])([A-Za-z0-9"\'. ]{50,}\\.)', 'g')
const str = `<>123Acdiiiiiiiiiiiiii iiiiiiiiiiiii iiii iiiiiii iiii iii iiiiiiiiiiiiiiiiiiiiiii iiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii iiiiiiiiii iiiiiiiiii iiiiiiiii iiiiii.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}