using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z]\w*)\s*\(\s*[A-Za-z]\w*\s+[A-Za-z]\w*\s*(?:,\s*[A-Za-z]\w*\s+[A-Za-z]\w*\s*)*\)";
string input = @"methodName(int a , String b,bool abc );";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}