re = /([A-Za-z]\w*)\s*\(\s*[A-Za-z]\w*\s+[A-Za-z]\w*\s*(?:,\s*[A-Za-z]\w*\s+[A-Za-z]\w*\s*)*\)/
str = 'methodName(int a , String b,bool abc );'
# Print the match result
str.match(re) do |match|
puts match.to_s
end