re = /^([0-9]{4}((0[1-9])|(1[0-2]))((0[1-9])|([1-2][0-9])|(3[0-1]))((([0-1][0-9])|(2[0-3]))[0-5][0-9][0-5][0-9](\.[0-9]{3}((\[[\+\-]?(0[0-9]|1[0-4])(:(00|30|45))?\])?)?)?)?)$/
str = '20150805110626.951[-11:00]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end