import Foundation
let pattern = #"(?i)((\bfoll[\wá-ú]{4,10})|(\bfoll([aeéoó][nsdr]?(?=[^\wáé])))|(\bfoll(?:([eéaá][ibsrdo][\wáé])))|(folleta))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
follándonoslas, follándonoslos,
follándonosla, follándonoslo, follándomelos, follándotelos, follándomelas, follándotelas, follándooslas, follándooslos, folletinescos, folletinescas, follándoselos, follándoselas, folletinistas,
follándosela, follándoosla, follándoselo, follándotelo, follándotela, folletinesca, folletinesco, folletinista, follándooslo, follándomela, follárnoslos, follándomelo, follárnoslas,
follándolos, follándoles, folletistas, follarÃamos, follándolas, follándonos, follárnoslo, follárselos, follároslos, follármelas, follártelas, follárnosla, follárselas, follártelos, follármelos, follároslas,
folloneras, folletones, follárselo, follársela, follándose, folletista, follártela, follábamos, follártelo, folloneros, follonerÃa, follándola, follándote, folláramos, follándoos, folláremos, follármela, follármelo, follásemos, follárosla, follándome, follároslo, follándolo, follándole, folletines, folladoras, folladores, follarÃais, follaremos, follajerÃa, follasteis,
follonero, folladora, follarlas, follonera, follaréis, follarais, follarÃan, follarlos, follareis, follarnos, follarles, folladnos, follarÃas, folliscas, follabais, folladles, folletero, folladlas, folladlos, follaseis,
folladla, follaban, follaren, follares, follarla, folladas, follador, follabas, follaras, folladlo, follados, follando, follamos, follajes, folladme, folladle, follaran, follarlo, follarme, follones, follarás, folletón, follaste, follases, follasen, follisca, folletÃn, folletos, follarÃa, follonÃa, follarse, follarse, follarte, follarle, follemos, follarán, follaron, follaros,
folléis, folleto, follase, follero, folleta, follaba, follada, follará, follado, follare, follaré, folláis, follaje, follara, follaos,
follen, folles, follad, follar, follan, follas, follón,
follo, folle, follé, folla, folló.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)