#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^4((?:\D*\d){3})((?:\D*\d){4})((?:\D*\d){4})((?:\D*\d){4})$"
Local $sString = "43 20 75 89 94 56 01 23" & @CRLF & _
"4 3 2 0 7 5 8 9 9 4 5 6 0 1 2 3" & @CRLF & _
"4320a7589b9456c0123" & @CRLF & _
"4320$7589$9456$0123" & @CRLF & _
"4320_7589_9456_0123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")