import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^4((?:\\D*\\d){3})((?:\\D*\\d){4})((?:\\D*\\d){4})((?:\\D*\\d){4})$";
final String string = "43 20 75 89 94 56 01 23\n"
+ "4 3 2 0 7 5 8 9 9 4 5 6 0 1 2 3\n"
+ "4320a7589b9456c0123\n"
+ "4320$7589$9456$0123\n"
+ "4320_7589_9456_0123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}