const regex = /^[a-zA-Z]+[\'-]{0,1}[a-zA-Z]+$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]+[\\\'-]{0,1}[a-zA-Z]+$', 'i')
const str = `Ak'sd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}