$re = '/^[a-zA-Z]+[\'-]{0,1}[a-zA-Z]+$/i';
$str = 'Ak\'sd';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);