package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)an`)
var str = `I have seen an ant and a fish togather.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}