$re = '/an/m';
$str = 'I have seen an ant and a fish togather.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);