$re = '/(?<=[T|t]he\s)(day|boy)/m';
$str = 'The day was bright, and the boy was happy.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);