package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)gr[ea]y`)
var str = `Does shasha gray has grey hair?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}