$re = '/gr[ea]y/m';
$str = 'Does shasha gray has grey hair?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);