import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9_-]+?)_[\\d\\w]{8}\\-(?:[\\d\\w]{4}\\-){3}[\\d\\w]{12}[_\\d\\w\\s-]*$";
final String string = "/body/RenderingA_6c91dd08-c318-4aa1-9883-bd0ed8af711_UnqiueKeyA/RenderingB_1a9cbcf1-e80f-4448-a21e-12e66f38c015_UniqueKeyB/RenderingC_1a9cbcf1-e80f-4448-a21e-12e66f38c015_UniqueKeyC";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}